Revenue is down
Incident Report for pdst
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 16:39 UTC
Identified
Revenue calculations are down starting 12/6. We are actively fixing this. Thank you for your patience.
Posted Dec 22, 2021 - 15:37 UTC
This incident affected: Dashboard.